Ruby 2.3.8

These docs were generated by RubyDocs.org.