Ruby 2.4.9

These docs were generated by RubyDocs.org.