Ruby 2.5.7

These docs were generated by RubyDocs.org.